USB sticks not recognized

  • Hi there,

    I'm a fairly new RasPad owner, I've had mine for a couple weeks now.  I've discovered a fairly major difficulty with the unit.  It won't recognize certain USB sticks plugged into any of the 3 USB 3.0 ports on the side.

    And by certain, I mean USB sticks that are rated for 3.0 speeds.  Older USB 2.0 rated USB sticks show up just fine.  I have looked for evidence of these drives using both the lsblk and lsusb commands.  They don't show up anywhere, although like I said, older USB drives show up just fine.  I have tried this in multiple operating systems:  Raspberry pi OS (32 bit & 64 bit) and Ubuntu Desktop 21.04 (64 bit).  I get exactly the same response in all of them.  All other USB devices (mice and keyboards, etc) seem to work just fine.

    Strangely, when I have an official Raspberry pi keyboard plugged in, I can plug in my newer USB drives into the USB hub on the back of the keyboard and then the system will recognize it.  I assume that's because the USB hub on the RPi keyboard is a USB 2.0 hub.

    Has anyone else had these issues?  Is there a fix for this?  This seems to be a moderately large issue.

    Please let me know.



  • Have you tried plugging the drive directly into the RPI itself is it then recognised? 

    yes keyboard hub is usb2

  • That's a great question, I'm sorry I forgot to include that in the orignal post.  Yes, I have tried plugging these USB sticks into the Pi directly and they work fine.  Also, I tried switching the interal USB jumper cable (that connects to the daughter board) between both USB 3.0 ports on the Pi with the same results.

    I am starting to wonder if I have a defective unit?  I assume this is not a common or known fault among other RasPads?

    Do you have any other possible explainations?

    Thanks very much for your input!


  • As other drives and devices work, that would lead me to think that its not defective but what could be the case is the usb hub inside the raspad doesnt support high speed usb drives as its design as a testing platform and not a daily use tablet, but i sure Support will weigh in on that.

  • Hmmm... it seems to me that the ports are advertised as being USB 3.0 ports.  And they colored blue which is supposed to be an indicator that they support USB 3.0 speeds (although I've seen exceptions).  I still wonder if there's something wrong with this unit.

    I'd love to contact RasPad Support.  Is there any direct way to do that besides posting in this forum?  I'd like to try to get this question answered fairly soon because I may have a narrowing window on my ability to exchange the unit the longer I wait.

    Hopefully Support will find me here!  Thanks again for taking the time to weigh in, I appreciate it.

  • @Troy Heidner

    When did you buy this product? It may be a problem with the USB cable.
    Please provide your order number (or backer number) and delivery address. After verification, we will issue you a new USB cable.

    Message steps:
    Click on the avatar --> click send a message  --> fill in the required content.

Please login to reply this topic!