Raspad won’t auto-rotate


  • I have ran Raspad os, and other Os and the raspad's screen wont rotate. I checked hardware and everything looks good. 



  • Hi @Efrain Santiago

    If no error is reported, please calibrate before starting automatic rotation.

    https://raspad.readthedocs.io/en/latest/faq/RasPad3-FAQ.html#q-the-direction-of-the-display-does-not-change-with-the-direction-of-the-screen


  • When you install any OS other than raspad OS the touch rotate wont work, as the software you need to make it work is specific to raspad os and has to be manually installed and configured from their GIT, its a real faff but i can help you do it if you want. Took me ages to find how to do it and would be nice if raspad team made it easier to do.

    You can get the sotware package needed from here:
    https://github.com/sunfounder/python-sh3001

    you then need to configure/calibrate it:
    Configure Touch Screen

    also make sure you have the acellshim plugged in correctly to the pi, you can attach an image if your unsure and will tell you if it is correct.


  • Hi @Phil Bennett 

    Thanks for these instructions. I am in a bit of the same boat. I installed the generic Raspian (latest). The good news is that for what I'm using it for, it allows me to complile some tools I need, when Raspad OS did not. 

    However, installing the python code from git seemed to be successful, but when I try and run the command for the calibrator, I get this:

    FileNotFoundError: [Errno 2] No such file or directory: '/home/pi/.config/lxsession/LXDE-pi/autostart'

    I'm wondering if there is something I'm missing with the install.


  • @Isaac Linder ok try this go to that location,( you may need to turn on show hidden files) and create a blank/empty file called " autostart " and then try to run the command again, see if that works. If not please let me know your exact version of " raspberry pi os " your running so i can install a copy and check, it hasnt been called rasbian for a little while now.


  • @Efrain Santiago Same issue. I was sent a replacement accelshim, but it doesn't seem to work either. So so so frustrrating!! I get the sensor recognised as being functioning but there is no 'red light' on the sensor. When I get the light working, then the software doesn't pick up the sensor!! And the calibrate script just returns errrors...


  • @Nick Crosby thats linux for you so many flavours you always have to work through errors step by step, and if thats not your thing then best bet is to stick with windows, but put the time in and it can be a very powerful tool.


  • @Nick Crosby 

    What system are you using? If it is not raspad os, please reinstall the software.
    After inserting the module into the Raspberry Pi, use the command to see if the i2c address of the device is detected.

    sudo i2cdetect -y 1

    Regarding the installation of the software, first clone the code base

    git clone https://github.com/sunfounder/python-sh3001.git


    After cloning is complete, enter the directory

    cd python-sh3001


    Install related library files

    sudo python3 install.py install


    Restart the Raspberry Pi after the installation is complete

    sudo reboot


    After restarting, run the following command to start automatic rotation

    sudo auto-rotator install

  • @Phil Bennett cheers! I will keep plugging away’


  • @RasPad Support Thank you, will try that. FWIW was using Raspad and running the i2cdetect command. Either the red light worked OR it was detected - but not simultaneously 


  • @Phil Bennett - Sorry that was probably me being new to Raspberry Pi. I used the top recommended version from the imager: I can try and install the proper device OS. However, for dependency reasons some of the software I was trying to install or compile wouldn't work with it. But I'll do a fresh install after backing up and make sure the auto-rotate works. I was less concerned with that when I had the original Raspad OS on there.


  • @Isaac Linder yer that raspberry pi os 32bit thats fine and will work, did you do as i said and manually create the autostart file in that location and try to run again ?? 


  • @Nick Crosby i didnt think i have ever seen a red light on my shim and its working fine. 😕


  • @Phil Bennett I did and got past that error. I failed to mention that. The new error is this:

    pi@raspberrypi:~/.config/lxsession/LXDE-pi $ sudo auto-rotator calibrate
    Traceback (most recent call last):
      File "/usr/local/bin/auto-rotator", line 11, in <module>
        load_entry_point('sh3001==0.0.1', 'console_scripts', 'auto-rotator')()
      File "/usr/local/lib/python3.7/dist-packages/sh3001-0.0.1-py3.7.egg/sh3001/__init__.py", line 117, in rotate
        sensor = Sh3001()
      File "/usr/local/lib/python3.7/dist-packages/sh3001-0.0.1-py3.7.egg/sh3001/sh3001.py", line 418, in __init__
        self.sh3001_init()
      File "/usr/local/lib/python3.7/dist-packages/sh3001-0.0.1-py3.7.egg/sh3001/sh3001.py", line 509, in sh3001_init
        regData = self.sh3001_read(self.SH3001_CHIP_ID,self.reg_status)
      File "/usr/local/lib/python3.7/dist-packages/sh3001-0.0.1-py3.7.egg/sh3001/sh3001.py", line 503, in sh3001_read
        return self.mem_read(data, self.SH3001_ADDRESS, reg_addr, timeout=5000, addr_size=8)
      File "/usr/local/lib/python3.7/dist-packages/sh3001-0.0.1-py3.7.egg/sh3001/i2c.py", line 134, in mem_read
        result = bytearray(self._i2c_read_i2c_block_data(addr, memaddr, num))
      File "/usr/local/lib/python3.7/dist-packages/sh3001-0.0.1-py3.7.egg/sh3001/i2c.py", line 36, in _i2c_read_i2c_block_data
        return self._smbus.read_i2c_block_data(addr, reg, num)
    OSError: [Errno 121] Remote I/O error
    

    And running a command from another instruction above yeilds this:

    pi@raspberrypi:~ $ sudo i2cdetect -y 1
         0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
    00:          -- -- -- -- -- -- -- -- -- -- -- -- -- 
    10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
    20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
    30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
    40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
    50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
    60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
    70: -- -- -- -- -- -- -- --                         
    pi@raspberrypi:~ $ 
    

  • @Isaac Linder ok that means the PI can not see the accelshim and why i2cdetect shows as empty,

    go to Menu / preferences / raspberry pi configuration

    click the interfaces tab

    enable i2c interface.

    click ok and restart the pi, when its booted back up run i2cdetect again and see if it shows up?

    i am assuming you have plugged the accelshim in correctly on the pi in the first 6 pins from the left as you look at the pi?


  • @Phil Bennett Thanks. I'm a complete idiot. The accelshim was still in my box. Not sure how I missed that. However, upon opening the case again, I also damaged my display cable with the screwdriver (no screw in that hole). Anyone have a quick tip on replacement cables?


  • @Isaac Linder depends which cable you damaged? do an image then i can tell you how easy it will be to fix, but that sound like it wont be a fun fix sorry.


  • @Phil Bennett  - It's the longer of the two L-shaped. It It only looked dented (which is still not great). I peeled the casing back a bit and don't see any hole in the shielding but I get a 'no display cable' now. Probably wrong thread for this, but if you have any ideas. I did ask about replacement parts on the contact form of the main site as well. Again thanks for all of your help and info though.


  • @Isaac Linder yer thats one for staff to answer sorry.

    @Nick Crosby did you get your working now too ??


  • Actually, I did get it working (for now). Not sure what I did. I assume a loose connection may still be at play. But works like a charm!


  • 1 / 2
Please login to reply this topic!