Ethernet failure


  • My ethernet port seems to be dead. Ifconfig says no packets, no errors, and there are not lights on the plugs. Was working last night but was dead when it rebooted this morning. Cable tested ok on another device. Got wifi to work ok but I need low latency, so the tablet is useless until I fix eth0.

     

    Anyone got any ideas what I can check next or is the hardware just done? USB works fine, lots of other stuff seems ok. Its just eth0 is off. Oh, the little ethernet icon is missing from the header bar.



  • @John Vreeland 

    Please send us a message about your order number or backer number.
    And attach your shipping address and telephone in order to arrange delivery.
    Message steps:
    Click on the avatar --> click send a message  --> fill in the required content.
    We will reissue a mainboard and the ethernet cable for you.


  • It failed on the road, so I am going to have another look at it again in my native habitat--try to eliminate some variables. Need another day to look. I need to know for sure.


  • I'm already on the second PCB (received one yesterday.

    Still no Ethernet.
    If I insert a cable into PI, everything works.

    If I use loopthrough and pcb socket, no connection.

    I was already provided with a new PCB, but same issue


  • @M.Y. Sluijter-Borms and @John Vreeland have you tested the eth link cable ( the one between pi and pcb), as i bet thats the issue and not the PCB? 


  • @Phil Bennett , @John Vreeland, @RasPad Support 

    I've tested following:

    PI on ethernet cable to switch:

    -MDI-MDIX-AUTO

    -Flowcontrol enable/disable/auto

    -Speed autonegotiate/fixed 10-100-1000 HD FD

    Everything works.

    Same I tried with both the interlink cables and a F-F cable connector: everything works

    Then I tried using various combinations of interlink and PCB (I have 2 of each) en all the above mentioned link settings in my switch for the specific port.

    With the SunFounder PCB in between, NOTHING WORKS on eth0.

    I've traced out the PCB and I suspect there is a MDI-MDIX issue because the pins on the inside and outside connectors are not 1:1 (pin 1 inside = pin 1 outside ... pin 8 = pin 8).
    Something is definitely wrong in the PCB traces. Either it's a pin-to-pin connection error or maybe an impedance/conductance issue making the pcb pasthrough incompatible with (gigabit) ethernet.

    sorry for my late reply.
    I will see in the coming days if I can beep out the connectors on the inside and outside of the pcb.

    I also reported my findings to RasPad customer support. Because they already supplied me with second PCB but that did not resolve the ethernet issues


Please login to reply this topic!