please fix your raspad launcher install script

  • I took a freshly formatted sd card, installed the latest raspberry pi os, downloaded and ran your script.

    It is broken, please fix it, and let me know when you have.

    Error happened in install process:
    Enable auto rotate error:
      Error:Traceback (most recent call last):
      File "/usr/local/bin/auto-rotator", line 11, in <module>
        load_entry_point('sh3001==0.0.1', 'console_scripts', 'auto-rotator')()
      File "/usr/lib/python3/dist-packages/pkg_resources/", line 489, in load_entry_point
        return get_distribution(dist).load_entry_point(group, name)
      File "/usr/lib/python3/dist-packages/pkg_resources/", line 2793, in load_entry_point
        return ep.load()
      File "/usr/lib/python3/dist-packages/pkg_resources/", line 2411, in load
        return self.resolve()
      File "/usr/lib/python3/dist-packages/pkg_resources/", line 2417, in resolve
        module = __import__(self.module_name, fromlist=['__name__'], level=0)
      File "/usr/local/lib/python3.7/dist-packages/sh3001-0.0.1-py3.7.egg/sh3001/", line 2, in <module>
        from sh3001.sh3001 import Sh3001
      File "/usr/local/lib/python3.7/dist-packages/sh3001-0.0.1-py3.7.egg/sh3001/", line 425
        def get_from_config(self, name, default=""):
    SyntaxError: invalid syntax

  • @John Windberg

    The code has been updated.

    cd ~/python-sh3001
    git pull
    sudo python3
    sudo reboot

    Execute again after the device restarts

    sudo auto-rotator calibrate

    For specific operations, please refer to the document

    or video

  • @RasPad Support 

    I'm sorry, what?

    the install instructions are here:

    What is python-sh3001?

    the install script is a shell script, not a python one.

    Again, what?


    has not been updated since May 19, just how do I get your updated version?

  • Pretty damn sure you did not update v1.4 of that zip. Sure am glad I didn't bother trying to redo what I have already done several times.

  • The code error has been fixed.

    You enter the root directory of the root directory sh3001 and execute it again.

    Use the git pull command to update the code, and then execute sudo python3 again.


  • @RasPad Support 

    Started again with a blank sd card and then a fresh raspberry pi install.

    Installation script ran without error then rebooted the pi.

    auto rotation is not working

    calibration command just freezes

    Auto rotate was one of the thigns that did work when I used the downloaded os image.

    Does not work when installed via the raspad launcher install script.

    (I'm assuming the updates made were not inside the downloaded zip file, but on things that the script would then download.)

  • @RasPad Support 

    Oh, and I would not call python-sh3001 a "root" directory. It just gets created within the raspad-launcher directory during the execution of the install script. 

    Thus if you followed the instructions it would be:


  • @John Windberg ok for one try not to be so confrontational to the support team they are not native english speakers so sometimes things get lost in translation.

    now to fix your issue.

    The code for the auto-rotation script has been updated. so to make it work you need to follow the commands given by the support team member as this will update the scrpt used to make rotation work. (Yes this is a python script and sh3001 is the model number of the accelshim you installed in your raspad3 well i hope you istalled it otherwise your going to look very silly).

    Acelshim (rotation module) circled in white

    cd ~/python-sh3001
    git pull
    sudo python3
    sudo reboot

    that will update the script that makes rotation work, when the raspad3 has rebooted, then you need to calibrate it or it still wont work, so do the next command.

    sudo auto-rotator calibrate

    how to do calibration:

    once that is complete you will have the rotation working.

  • Just installed my Raspad and set up. I also had a problem with the auto-rotate script, but I noticed it seemed to be an issue with the 'apt update' instruction. when I ran this instruction in the terminal, it raised an issue with teh stability setting and asked if I wanted to continue anyway. I answered y, it installed OK, when i ran the python install again it proceeded fine.

    The documentation should make clearer that auto-rotate only works for the two landscape orientation (if that is the case). The unbox/reviewer on the Raspad home page says it does not work holding the Raspad in portrait and it does not seem to accept portrait for me, but it doesn't feel that the Raspad is designed to function in portrait anyway (for instance, if you have anything in a USB port you need to have that side of the Raspad on top, so the device rests on the switches and turns itself off!)

  • @Luke Howard apologies, portrait mode does work although the screen does not adjust properly

  • @Luke Howard screen rotate does work correctly, in both portrait AND landscape views, i have been using mine in both for awhile. The fact that it wont stand on its side with anything plugged in is no different to any mobile phone of tablet on the market they all have this same issue.

    If you having problems with you setup then please provide full details of what steps you have done and then i can help you sort your issue.

Please login to reply this topic!