USB ports not discovering USB stick/drives (Raspberry Pi OS)

  • I created a brand new sd card boot - for Raspberry Pi OS

      booted fine, and wanted to create another copy, so I plugged in a new USB SanDisk Ultra 64g into one of the USB 3.0 ports on the side of the Raspad3. It was NOT detected by the OS.

      I tried all the external ports none worked.

      I then powered down and removed the newly created sd card, and put it into my other Rpi4 booted fine, and plugged in my USB SanDisk Ultra 64g, and it was detected immediately  - and launched SD Copier and successfully made my copy.

      I also noticed another problem, using the Raspberry Pi Imager app on the Raspad OS - it doesn't work. It doesn't display the Operating System nor Storage - pull-down selection options.

    (EDIT: Just checked it doesn't work on Raspberry Pi OS either - on the Raspd3 hardware)

  • @Thomas A. Cichowicz 

    This software problem, not done well, is the official problem of the Raspberry Pi. In fact, this place can be clicked, but the interface does not look good after clicking it.

  • I have run without any problems Raspberry Pi Imager  on any other hardware. Using the same SD Card or USB drive image that has the problem on Raspad.


     I just take it out from the Raspad and put it in another Rpi4 and the software works fine.

    The Problem IS the Raspad3.

  • @RasPad Support 

      Specifically, the Problem is your Raspad Launcher -- as soon as that is installed you get those corrupted screens from Raspberry OS Imager, and it doesn't work.

  • @Thomas A. Cichowicz 

    Thank you for the feedback. It is indeed a problem with Raspad Launcher. It is expected that the problem will be resolved next working day.

Please login to reply this topic!