No Cable on Boot Up


  • I have seen the other posts referenci9ng the No Cable on boot up, read them all and the responses and tried them all to no avail!  What is the issue here, after reseating all the cables (5 times now!!!) downloading a new os and flashing it to a known workingsd card, connecting the RASPAD3 to an external monitor I still get the same "No Cable" message on boot up!!!  The RASPAD will be returned on Sunday unless I (you) can give me a decent remedy for this, I don't have the time nor the patience to mess around with something I now consider to be "NOT FIT FOR PURPOSE!"



  • ok so what exactly is your issue, because as you can see from all the other posts " no cable " can mean alot of things. If you dont say exactly what you are seeing then no one will ever be able to help you.

    do you mean the pi boots but the screen stays blank?
    do you mean the screen flashes "no display" then go on to boot into os?
    im guessing by the fact you put " on boot " that you dont mean on shutdown then raspad stays on and displays " no Cable " until you press and hold the power button to turn it off?

    you say you have tried " everything " what exactly have you tried?

    when you boot with an external display connected do you get an ouput on the second monitor? and when you go to screen configuration does it show 1 or 2 sceens?

    what OS are you installing ? 

    Can you provide images of the error AND the inside of your raspad so i can see how you have it connected?


  • When I press and hold  the power button, the 3 green lights and the red light all come on, after a few seconds the "No Cable" message comes on for 2-3 seconds then disappears, the screen is blank, the lights are still lit and the fan is running (I personally don't think the fan is too loud) and that's it, thats how it stays until I power it off.  All cables are correctly installed as per the Raspad in struction booklet.  I'm using the Raspad OS.  I have been building my own pc's for 20 years now and been involed in IT since the late 80's so I have built up a wealth of experience in this field and know what I am doing but this is my first foray into tablets.


  • @Steve Thompson

    Ok as i supected the fact "no cable" is shown didnt tell the whole story, all that message is, is the main board in the raspad3 saying that it is not recieving a HDMI output from you pi so can you now  answer the following so i can better assist you.

    When you boot with an external display connected do you get an ouput on the second monitor? and if you do when you go to screen configuration does it show 1 or 2 screens?

    Can you provide images of the inside of your raspad so i can see how you have it connected?

    Also to note raspad OS no longer exists and has been replaced with Raspberry PI OS and a custom launcher, these can be found respectively at.

    https://www.raspberrypi.org/software/ and

    https://github.com/raspad-tablet/raspad-launcher/blob/main/docs/installation-guide.md


  • Whe I try to boot with an external monitor attached to the Raspad 3 I get notthing at all on the external monitor and just the No Cable message on the Raspad then blank screen.

    No Cable Message


  • @Steve Thompson ok please provide the image of inside the raspad3, so i can see the connections.

    Then remove the two HDI cables, and plug the external display directly to the pi and try to boot do you now get an output. make sure you plug to HDMI port 1 (the 1 next to the usb-c port)


  • I've swaqpped out the RPI 4 that I bought alongside the Raspad for a known working RPI4 that I was using for other things.  It looks like the "new" RPI is the problem as my older one has booted the Raspad fine and connected to the wireless keyboard fine and my router so I'm going to have a play with it and see where Iget to before looking at the RPI4 that isn't working.

    I just didn't recko0n on a dodgy RPI 4 as the problem.


  • @Steve Thompson well there we go then glad you found your problem, that why i ask so many questions to start, that way we always get to the bottom of the problem. 


  • I have 3 Raspads for my kids and all of them do the same with working RPi. But I will again test them and the outputs and get back. 

    Thanks. 


  • @Jozua Hattingh

    ok so what exactly is your issue with you raspad3s, because as you can see from all the other posts " no cable " can mean alot of things. If you dont say exactly what you are seeing then no one will ever be able to help you.

    do you mean the pi boots but the screen stays blank?
    do you mean the screen flashes "no display" then goes on to boot into os?
    im guessing by the fact you put " on boot " that you dont mean on shutdown then raspad stays on and displays " no Cable " until you press and hold the power button to turn it off?

    when you boot with an external display connected do you get an ouput on the second monitor? and when you go to screen configuration does it show 1 or 2 sceens?

    what OS are you installing ? 

    Can you provide images of the error AND the inside of your raspad3s so i can see how you have them connected?


  • It seems likely to me that the 'No cable' message is generated by the Raspad display system when it does not find an Raspberry pi. I see it when I have shut down the Pi before I power off the Raspad. I may be telling people what they already know but I haven't seen this mentioned in the discussion, and it might help debug 


  • @Luke Howard yes thats correct, its generated by the LCD controller and should really say " no signal " same as if you had a normal monitor, but as i have said the team behide raspad3 are not native english speakers so some things are not worded exactly as we would expect in english.


Please login to reply this topic!